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1 工具简介 

HUAWEI DevEco Studio（以下简称 DevEco Studio）是基于 IntelliJ IDEA Community

开源版本打造，面向华为终端全场景多设备的一站式集成开发环境（IDE），为开发者提

供工程模板创建、开发、编译、调试、发布等 E2E 的 HarmonyOS 应用开发服务。通过使

用 DevEco Studio，开发者可以更高效的开发具备 HarmonyOS 分布式能力的应用，进而

提升创新效率。 

作为一款开发工具，除了具有基本的代码开发、编译构建及调测等功能外，DevEco 

Studio 还具有如下特点： 
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⚫ 多设备统一开发环境：支持多种 HarmonyOS 设备的应用开发，包括手机

（Phone）、平板（Tablet）、车机（Car）、智慧屏（TV）、智能穿戴

（Wearable），轻量级智能穿戴（LiteWearable）和智慧视觉（Smart Vision）设

备。 

⚫ 支持多语言的代码开发和调试：包括 Java、XML（Extensible Markup 

Language）、C/C++ 、 JS（JavaScript）、CSS（Cascading Style Sheets）和

HML（HarmonyOS Markup Language）。 

⚫ 支持 FA（Feature Ability）和 PA（Particle Ability）快速开发：通过工程向导快

速创建 FA/PA 工程模板，一键式打包成 HAP（HarmonyOS Ability Package）。 

⚫ 支持分布式多端应用开发：一个工程和一份代码可跨设备运行，支持不同设备界面的

实时预览和差异化开发，实现代码的最大化重用。 

⚫ 支持多设备模拟器：提供多设备的模拟器资源，包括手机、平板、车机、智慧屏、智

能穿戴设备的模拟器，方便开发者高效调试。 

⚫ 支持多设备预览器：提供 JS 和 Java 预览器功能，可以实时查看应用的布局效果，支

持实时预览和动态预览；同时还支持多设备同时预览，查看同一个布局文件在不同设

备上的呈现效果。 
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2 快速开始 

2.1 下载与安装软件 

DevEco Studio 支持 Windows 和 Mac 版本，下面将针对两种操作系统的软件安装方式

进行介绍。 

2.1.1 Windows 环境 

2.1.1.1 运行环境要求 

为保证 DevEco Studio 正常运行，建议您的电脑配置满足如下要求： 

• 操作系统：Windows10 64 位 

• 内存：8GB 及以上 

• 硬盘：100GB 及以上 

• 分辨率：1280*800 像素及以上 

2.1.1.2 下载和安装 Node.js 

Node.js 应用于开发 JS 应用和运行预览器功能，是开发 HarmonyOS 应用过

程中必备的软件。 

1. 登录 Node.js 官方网站，下载 Node.js 软件包。请选择 LTS 版本，Windows 64 位对应

的软件包。 

https://nodejs.org/en/download/
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2. 点击下载后的软件包进行安装，全部按照默认设置点击 Next，直至 Finish。安装过程中，

Node.js 会自动在系统的 path 环境变量中配置 node.exe 的目录路径。 

2.1.1.3 下载和安装 DevEco Studio 

DevEco Studio 的编译构建依赖 JDK，DevEco Studio 预置了 Open JDK，版本为 1.8，

安装过程中会自动安装 JDK。 

1. 登录 HarmonysOS 应用开发门户，点击右上角注册按钮，注册开发者帐号，注册指导参考注册华为帐

号。如果已有华为开发者帐号，请直接点击登录按钮。 

说明 

使用 DevEco Studio 远程模拟器需要华为帐号进行实名认证，建议在注册华为帐号后，立即提交实名认

证审核，认证方式包括“个人实名认证”和“企业实名认证”，详情请参考实名认证。 

2. 进入 HUAWEI DevEco Studio 产品页，下载 DevEco Studio 安装包。 
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3. 双击下载的“deveco-studio-xxxx.exe”，进入 DevEco Studio 安装向导，在如下安装选项界面勾选

DevEco Studio launcher 后，点击 Next，直至安装完成。 

   

 

2.1.2 Mac 环境 

2.1.2.1 运行环境要求 

为保证 DevEco Studio 正常运行，建议您的电脑配置满足如下要求： 

• 操作系统：Mac 10.13/10.14/10.15 

• 内存：8GB 及以上 

• 硬盘：100GB 及以上 

• 分辨率：1280*800 像素及以上 
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2.1.2.2 下载和安装 Node.js 

Node.js 应用于开发 JS 应用和运行预览器功能，是开发 HarmonyOS 应用过

程中必备的软件。 

1. 登录 Node.js 官方网站，下载 Node.js 软件包。请选择 LTS 版本，Windows 64 位对应

的软件包。 

 

2. 点击下载后的软件包进行安装，全部按照默认设置点击 Next，直至 Finish。安装过程

中，Node.js 会自动在系统的 path 环境变量中配置 node.exe 的目录路径。 

https://nodejs.org/en/download/
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2.1.2.3 下载和安装 DevEco Studio 

DevEco Studio 的编译构建依赖 JDK，DevEco Studio 预置了 Open JDK，版

本为 1.8，安装过程中会自动安装 JDK。 

1. 登录 HarmonysOS 应用开发门户，点击右上角注册按钮，注册开发者帐

号，注册指导参考注册华为开发者联盟帐号。如果已有华为开发者联盟帐号，请直

接点击登录按钮。 

说明 

使用 DevEco Studio 远程模拟器需要华为开发者联盟帐号进行实名认证，建议在注册华为开发者联盟帐号

后，立即提交实名认证审核，认证方式包括“个人实名认证”和“企业实名认证”，详情请参考实名认证。 

2. 进入 HUAWEI DevEco Studio 产品页，下载 DevEco Studio 安装包。 

3. 双击下载的“deveco-studio-xxxx.dmg”软件包。 

 

4. 安装完成后，先不要启动 DevEco Studio，接下来请根据配置开发环境，检

查和配置开发环境。 

2.2 配置开发环境 

DevEco Studio 开发环境需要依赖于网络环境，需要连接上网络才能确保工具的正常使

用，可以根据如下两种情况来配置开发环境： 

https://developer.harmonyos.com/cn/docs/documentation/doc-guides/environment_config-0000001052902427
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• 如果可以直接访问 Internet，只需进行 H2 设置 npm 仓库和下载 HarmonyOS SDK 操作。 

• 如果网络不能直接访问 Internet，需要通过代理服务器才可以访问，请根据本章节内容逐条设置开发环

境。 

2.2.1 npm 设置 

2.2.1.1 设置 npm 代理 

只有在同时满足以下两个条件时，需要配置 npm 代理，否则，请跳过本章节。 

• 需要使用 JS 语言开发 HarmonyOS 应用。 

• 网络不能直接访问 Internet，而是需要通过代理服务器才可以访问。这种情况下，配置 npm 代理，便于

从 npm 服务器下载 JS 依赖。 

打开命令行工具，按照如下方式进行 npm 代理设置和验证。 

1. 执行如下命令设置 npm 代理。 

o 如果使用的代理服务器需要认证，请按照如下方式进行设置（请将 user、password、proxyserver 和

port 按照实际代理服务器进行修改）。 

1. npm config set proxy http://user:password@proxyserver:port 

2. npm config set https-proxy http://user:password@proxyserver:port 

o 如果使用的代理服务器不需要认证（不需要帐号和密码），请按照如下方式进行设置。 

1. npm config set proxy http:proxyserver:port 

2. npm config set https-proxy http:proxyserver:port 

2. 代理设置完成后，执行如下命令进行验证。 

o npm info express 

执行结果如下图所示，则说明代理设置成功。 



文档内容来自鸿蒙官方网站，鸿蒙学堂 hmxt.org 整理 

9 

 

 

2.2.1.2 设置 npm 仓库 

为了提升下载 JS SDK 时，使用 npm 安装 JS 依赖的速度，建议在命令行工具中执行如下

命令，重新设置 npm 仓库地址。 

1. npm config set registry https://mirrors.huaweicloud.com/repository/npm/ 

2.2.2 设置 Gradle 代理 

如果网络不能直接访问 Internet，而是需要通过代理服务器才可以访问，这种情况下，需

要设置 Gradle 代理，来访问和下载 Gradle 所需的依赖。否则，请跳过本章节。 

1. 打开“此电脑”，在文件夹地址栏中输入%userprofile%，进入个人数据界面。 
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2. 创建一个文件夹，命令为.gradle.。如果已有.gradle 文件夹，请跳过此操作。 

3. 进入.gradle 文件夹，新建一个文本文档，命名为 gradle，并修改后缀为.properties。 

4. 打开 gradle.properties 文件中，添加如下脚本，然后保存。 

其中代理服务器、端口、用户名、密码和不使用代理的域名，请根据实际代理情况进行修改。其中不使用

代理的 “nonProxyHosts”的配置间隔符是 “|”。 

1. systemProp.http.proxyHost=proxy.server.com 

2. systemProp.http.proxyPort=8080 

3. systemProp.http.nonProxyHosts=*.company.com|10.*|100.* 

4. systemProp.http.proxyUser=userId 

5. systemProp.http.proxyPassword=password 

6. systemProp.https.proxyHost=proxy.server.com 

7. systemProp.https.proxyPort=8080 

8. systemProp.https.nonProxyHosts=*.company.com|10.*|100.* 

9. systemProp.https.proxyUser=userId 

10. systemProp.https.proxyPassword=password 

2.2.3 设置 DevEco Studio 代理 

如果网络不能直接访问 Internet，而需要通过代理服务器才可以访问，这种情况下，需要

设置 DevEco Studio 代理，来访问和下载外部资源。否则，请跳过本章节。 

1. 运行已安装的 DevEco Studio，首次使用，请选择 Do not import settings，点击 OK。 

2. 根据 DevEco Studio 欢迎界面的提示，点击 Setup Proxy，或者在欢迎页点击 Configure > 

Settings > Appearance&Behavior > System Settings > HTTP Proxy 进入 HTTP Proxy 设置界

面。 
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3. 设置 DevEco Studio 的 HTTP Proxy 信息。 

o HTTP 配置项，设置代理服务器信息。 

▪ Host name：代理服务器主机名或 IP 地址。 

▪ Port number：代理服务器对应的端口号。 

▪ No proxy for：不需要通过代理服务器访问的 URL 或者 IP 地址（地址之间用英文逗号分隔）。 

o Proxy authentication 配置项，如果代理服务器需要通过认证鉴权才能访问，则需要设置。否则，请跳

过该配置项。 

▪ Login：访问代理服务器的用户名。 

▪ Password：访问代理服务器的密码。 

▪ Remember：勾选，记住密码。 

 

4. 配置完成后，点击 Check connection，输入网络地址（如：https://developer.harmonyos.com），检

查网络连通性。提示“Connection successful”表示代理设置成功。 

5. 点击 OK 按钮完成 DevEco Studio 代理配置。 
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6. DevEco Studio 代理设置完成后，会提示安装 HarmonyOS SDK，可以点击 Next 下载到默认目录中；

如果想更改 SDK 的存储目录，请点击 Cancel，并根据下载 HarmonyOS SDK 进行操作。 

 

2.2.4 下载 HarmonyOS SDK 

Devco Studio 提供 SDK Manager 统一管理 SDK 及工具链，下载各种编程语言的 SDK

包时，SDK Manager 会自动下载该 SDK 包依赖的工具链，具体说明请参考下表。 

类别 包名 说明 默认是否下载 参考 

SDK 

Native C/C++语言 SDK 包。 x 
《Native API 参

考》 

JS JS 语言 SDK 包。 x 《JS API 参考》 

Java Java 语言 SDK 包。 √ 
《Java API 参

考》 

https://developer.harmonyos.com/cn/docs/documentation/image-0000001055673652
https://developer.harmonyos.com/cn/docs/documentation/image-0000001055673652
https://developer.harmonyos.com/cn/docs/documentation/js-framework-file-0000000000611396
https://developer.harmonyos.com/cn/docs/documentation/overview-0000001054518434
https://developer.harmonyos.com/cn/docs/documentation/overview-0000001054518434
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类别 包名 说明 默认是否下载 参考 

SDK Tool 

Toolchains 

SDK 工具链，

HarmonyOS 应用开

发必备工具集，包括编

译、打包、签名、数据

库管理等工具的集合。 

√ - 

Previewer 

HarmonyOS 应用预

览器，在开发过程中可

以动态预览 Phone、

TV、Wearable、

LiteWearable 等设备

的应用效果，支持 JS

和 Java 应用预览。 

x 
使用预览器查看

应用效果 

 

1. 在菜单栏点击 Configure > Settings 或者默认快捷键 Ctrl+Alt+S，打开 Settings 配置界面。 

2. 进入 Appearance&Behavior > System Settings > HarmonyOS SDK 菜单界面，点击 Edit 按钮，

设置 HarmonyOS SDK 存储路径。 

 

https://developer.harmonyos.com/cn/docs/documentation/doc-guides/previewer-0000001054328973
https://developer.harmonyos.com/cn/docs/documentation/doc-guides/previewer-0000001054328973
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3. 选择 HarmonyOS SDK 存储路径，然后点击 Next。在弹出的 License Agreement 窗口，点击 Accept

开始下载 SDK。 

说明 

如果本地已有 SDK 包，请选择本地已有 SDK 包的存储路径，DevEco Studio 会增量更新 SDK 及工具

链。 

4. 等待 HarmonyOS SDK 及工具下载完成，点击 Finish，可以看到默认的 SDK Platforms>Java SDK 及

SDK Tools>Toolchains 已完成下载。 

   

 

5. 如果工程还会用到 JS 或者 C/C++语言，请在 SDK Platform 中，勾选对应的 SDK 包，点击 Apply，

SDK Manager 会自动将 SDK 包和工具链，下载到 3 中设置的 SDK 存储路径中。 

   

https://developer.harmonyos.com/cn/docs/documentation/doc-guides/environment_config-0000001052902427#ZH-CN_TOPIC_0000001052902427__li14338427102017
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2.3 创建和运行 Hello World 

DevEco Studio 开发环境配置完成后，可以通过运行 HelloWorld 工程来验证环境设置是

否正确。以 Wearable 工程为例，在 Wearable 远程模拟器中运行该工程。 

1. 打开 DevEco Studio，在欢迎页点击 Create HarmonyOS Project，创建一个新工程。 

2. 选择设备类型和模板，以 Phone 为例，选择 Empty Feature Ability(Java)，点击 Next。 
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3. 填写项目相关信息，保持默认值即可，点击 Finish。 

4. 工程创建完成后，DevEco Studio 会自动进行工程的同步，同步成功如下图所示。首次创建工程时，会

自动下载 Gradle 工具，时间较长，请耐心等待。 

   

5. 在 DevEco Studio 菜单栏，点击 Tools > HVD Manager。首次使用模拟器，需下载模拟器相关资源，

请点击 OK，等待资源下载完成后，请重新点击 Tools > HVD Manager。 

   

6. 在浏览器中弹出华为帐号登录界面，请输入已实名认证的华为开发者联盟帐号的用户名和密码进行登录。 

7. 登录后，请点击界面的允许按钮进行授权。 

   



文档内容来自鸿蒙官方网站，鸿蒙学堂 hmxt.org 整理 

17 

 

8. 在设备列表中，选择 Phone 设备，并点击按钮，运行模拟器。 

   

9. 点击 DevEco Studio 工具栏中的按钮运行工程，或使用默认快捷键 Shift+F10（Mac 为 Control+R）

运行工程。 

10. 在弹出的 Select Deployment Target 界面选择 Connected Devices，点击 OK 按钮。 

 

11. DevEco Studio 会启动应用的编译构建，完成后应用即可运行在模拟器上。 
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您已成功运行了第一个 HarmonyOS 应用，接下来，可以通过一个简单的 DEMO 工程示

例，来详细了解 HarmonyOS 应用的开发过程。 
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3 工程管理 

3.1 HarmonyOS 工程介绍 

3.1.1 HarmonyOS APP 工程结构 

在进行 HarmonyOS 应用开发前，您应该掌握 HarmonyOS 应用的逻辑结构。 

HarmonyOS 应用发布形态为 APP Pack（Application Package，简称 APP），它是由

一个或多个 HAP（HarmonyOS Ability Package）包以及描述 APP Pack 属性的

pack.info 文件组成。 

一个 HAP 在工程目录中对应一个 Module，它是由代码、资源、第三方库及应用清单文件

组成，可以分为 Entry 和 Feature 两种类型。 

• Entry：应用的主模块。一个 APP 中，对于同一设备类型必须有且只有一个 entry 类型的

HAP，可独立安装运行。 

• Feature：应用的动态特性模块。一个 APP 可以包含一个或多个 feature 类型的 HAP，也

可以不含。 

HAP 是 Ability 的部署包，HarmonyOS 应用代码围绕 Ability 组件展开，它是由一个或

多个 Ability 组成。Ability 分为两种类型：FA（Feature Ability）和 PA（Particle 

Ability）。FA/PA 是应用的基本组成单元，能够实现特定的业务功能。FA 有 UI 界面，而

PA 无 UI 界面。 
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3.1.2 工程目录结构 

3.1.2.1 Java 工程目录结构 

Java 工程目录结构如下图所示。 
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• .gradle：Gradle 配置文件，由系统自动生成，一般情况下不需要进行修改。 

• entry：默认启动模块（主模块），开发者用于编写源码文件以及开发资源文件的目

录。 

▪ entry>libs：用于存放 entry 模块的依赖文件。 

▪ entry>src>main>Java：用于存放 Java 源码。 

▪ entry>src>main>resources：用于存放应用所用到的资源文件，如图形、

多媒体、字符串、布局文件等。关于资源文件的详细说明请参考资源文件的分

类。 

资源目录 资源文件说明 

base>element 

包括字符串、整型数、颜色、样式等资源的 json 文件。每个资源均

由 json 格式进行定义，例如： 

o boolean.json：布尔型 

o color.json：颜色 

o float.json：浮点型 

o intarray.json：整型数组 

o integer.json：整型 

o pattern.json：样式 

o plural.json：复数形式 

o strarray.json：字符串数组 

o strings.json：字符串值。 

base>graphic 

xml 类型的可绘制资源，如 SVG（Scalable Vector Graphics）可缩

放矢量图形文件、基本的几何图形（如矩形、圆形、线等）shape 资

源等。 

base>layout xml 格式的界面布局文件。 
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资源目录 资源文件说明 

base>media 
多媒体文件，如图形、视频、音频等文件，支持的文件格式包

括：.png、.gif、.mp3、.mp4 等。 

base>profile 
用于存储任意格式的原始资源文件。区别在于 rawfile 不会根据设备

的状态去匹配不同的资源，需要指定文件路径和文件名进行引用。 
rawfile 

• entry>src>main>config.json：HAP 清单文件，详细说明请参考 config.json

配置文件介绍。 

• entry>src>test：编写代码单元测试代码的目录，运行在本地 Java 虚拟机

（JVM）上。 

• entry>.gitignore：标识 git 版本管理需要忽略的文件。 

• entry>build.gradle：entry 模块的编译配置文件。 

 

3.1.2.2 JS 工程目录结构 

JS 工程目录结构如下图所示。 
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• common 目录：可选，用于存放公共资源文件，如媒体资源、自定义组件和 JS

文档等。 

• i18n 目录：可选，用于存放多语言的 json 文件，可以在该目录下定义应用在不同

语言系统下显示的内容，如应用文本词条、图片路径等，详情请参考多语言支持。 

• pages 目录：pages 文件夹下可以包含 1 个或多个页面，每个页面都需要创建一

个文件夹（如图中的 index）。页面文件夹下主要包含 3 种文件类型：css、js 和

hml 文件。 

▪ pages>index>index.hml 文件：hml 文件定义了页面的布局结构，使用

到的组件，以及这些组件的层级关系，详情请参考 HML 语法参考。 

▪ pages>index>index.css 文件：css 文件定义了页面的样式与布局，包

含样式选择器和各种样式属性等，详情请参考 CSS 语法参考。 
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▪ pages>index>index.js 文件：js 文件描述了页面的行为逻辑，此文件里

定义了页面里所用到的所有的逻辑关系，比如数据、事件等，详情请参考

JS 语法参考。 

• resources：可选，用于存放资源配置文件，比如：全局样式、多分辨率加载等配

置文件。resources 资源引用示例请参考根据设备分辨率加载图片。 

• app.js 文件：全局的 JavaScript 逻辑文件和应用的生命周期管理。 

 

3.2 支持的设备模板和编程语言 

DevEco Studio 支持包括手机、平板、车机、智慧屏、智能穿戴、轻量级智能穿戴和智慧

视觉设备的 HarmonyOS 应用开发，可以根据工程向导轻松创建适应于各类设备的工程，

并自动生成对应的代码和资源模板。同时，DevEco Studio 还提供了多种编程语言供开发

者进行 HarmonyOS 应用开发，包括 Java、JS 和 C/C++三种编程语言。因此，在创建对

应设备的工程时，工具会预置多种 Ability 的模板，并推荐您使用适合的开发语言。 
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支持的各设备类型工程模板和对应开发语言的对应关系，如下表所示。 

Device 模板名称 模板说明 

Phone 

Empty Feature Ability(JS) 

使用 JS 语言开发，用于 Phone 设备的 Feature 

Ability 模板。JS 提供页面布局（Java 提供 JS 

FA 的运行环境和入口），居中显示文本内容

Hello World 或您好 世界，显示语言与系统语

言一致。 

Empty Feature 

Ability(Java) 

使用 Java 语言开发，用于 Phone 设备的

Feature Ability 模板，使用 XML 布局，居中显

示“Hello World”。 

Business Card 

Ability(Java) 

使用 Java 语言开发，用于 Phone 设备的

Feature Ability 模板，使用 XML 布局。展示了

一个名片详情页的样例工程，主要由一个

ScrollView 嵌套的两个 ListContainer 组成。 

Category List Ability(Java) 

使用 Java 语言开发，用于 Phone 设备的

Feature Ability 模板，使用 XML 布局，该模板

由标题栏和单行列表组成，其中单行列表被分

为多个分组，单行列表中的每一项由左侧文本

和右侧文本组成。该模板还提供了

ListContainer 和 RecycleItemProvider 的接口

使用方法示例。 

News Feature Ability(Java) 

使用 Java 语言开发，用于 Phone 设备的

Feature Ability 模板，使用 XML 布局，展示了

标准的设备发现迁移的功能，实现了新闻可以

跨设备分享的场景 

Profile Picture List 

Ability(Java) 

使用 Java 语言开发，用于 Phone 设备的

Feature Ability 模板，由标题栏、双行列表和

底部选项栏构成。该头像列表模板包括两个布

局文件，一个是用于提供整体 Feature Ability

布局，另一个用于提供页面内列表 Item 布局。
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Device 模板名称 模板说明 

该模板演示了标题栏、复杂列表及底部选项栏

的使用及数据绑定方式。 

Settings Feature 

Ability(Java) 

使用 Java 开发，用于 Phone 设备的 Feature 

Ability 模板，使用 XML 布局，由标题栏和一

个列表组成。列表部分可设置单行和双行，并

分别提供对应的 XML 布局文件。单行列表由左

侧文本和右侧文本组成；双行列表由左侧图标

以及双行描述文本和右侧开关组成，并提供开

关状态持久化示例。 

Shopping Feature 

Ability(Java) 

使用 Java 语言开发，用于 Phone 设备的

Feature Ability 模板，使用 XML 布局，展示了

标准的设备发现迁移的功能，实现了商品可以

跨设备分享的场景。 

Splash Screen 

Ability(Java) 

使用 Java 语言开发，用于 Phone 设备的

Feature Ability 模板，使用 XML 布局。展示了

一个应用启动页模板，实现了页面跳转。 

Tablet 

Empty Feature Ability(JS) 

使用 JS 语言开发，用于 Tablet 设备的 Feature 

Ability 模板。JS 提供页面布局（Java 提供 JS 

FA 的运行环境和入口），居中显示文本内容

Hello World 或您好 世界，显示语言与系统语

言一致。 

Empty Feature 

Ability(Java) 

使用 Java 语言开发，用于 Tablet 设备的

Feature Ability 模板，使用 XML 布局，居中显

示“Hello World”。 

Car 
Empty Feature Ability

（Java） 

使用 Java 语言开发，用于 Car 设备的 Feature 

Ability 模板，使用 XML 布局，居中显示

“Hello World”。 
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Device 模板名称 模板说明 

Native C++ 

使用 Java 和 C++语言开发，用于 Car 设备的

Feature Ability 模板，作为鸿蒙应用调用 C++

代码的示例工程，界面显示“Hello from JNI 

C ++ codes”。 

TV 

Empty Feature Ability

（JS） 

使用 JS 语言开发，用于 TV 设备的 Feature 

Ability 模板。JS 提供页面布局（Java 提供 JS 

FA 的运行环境和入口），居中显示文本内容

Hello World 或您好 世界，显示语言与系统语

言一致。 

Empty Feature Ability

（Java） 

使用 Java 语言开发，用于 TV 设备的 Feature 

Ability 模板，使用 XML 布局，居中显示

“Hello World”。 

List Feature Ability（JS） 

使用 JS 语言开发，用于 TV 设备的 Feature 

Ability 模板。JS 提供页面布局（Java 提供 JS 

FA 的运行环境和入口），展示一个常用的列表

页面，标题和多行列表在左侧，右侧可以添加

配图。 

Tab Feature Ability（JS） 

使用 JS 语言开发，用于 TV 设备的 Feature 

Ability 模板。JS 提供页面布局（Java 提供 JS 

FA 的运行环境和入口），展示一个常用的 Tab

页签页面，每个页签对应一个视图，通过切换

页签可以快速浏览每个视图，每个视图内可以

添加副标题和多张图片。 

Wearable 
Empty Feature Ability

（JS） 

使用 JS 语言开发，用于 Wearable 设备的

Feature Ability 模板。JS 提供页面布局（Java

提供 JS FA 的运行环境和入口），居中显示文

本内容 Hello World 或您好 世界，显示语言与

系统语言一致。 
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Device 模板名称 模板说明 

Empty Feature Ability

（Java） 

使用 Java 语言开发，用于 Wearable 设备的

Feature Ability 模板，使用 XML 布局，居中显

示“Hello World”。 

List Feature Ability（JS） 

使用 JS 语言开发，用于 Wearable 设备的

Feature Ability 模板。JS 提供页面布局（Java

提供 JS FA 的运行环境和入口），展示一个常

用的 List 页面，每一个 Item 包含栏目项以及副

标题。 

Lite 

Wearable 

Empty Feature Ability 

使用 JavaScript 语言开发，用于 Lite 

Wearable 设备的 Feature Ability 模板，包含

一个简单的 Hello World 文本。该模板包含两

个组件：div 和 text，同时演示了数据绑定的使

用方式。 

List Feature Ability 

使用 JavaScript 语言开发，用于 Lite 

Wearable 设备的 Feature Ability 模板，包含

一个可滑动的列表。此模板包含 4 个组件：

list、list-item、text、div，同时演示了 for 指

令进行列表渲染的方式。 

Smart 

Vision 

Empty Feature Ability 

使用 JavaScript 语言开发，用于 Smart Vision

设备的 Feature Ability 模板，包含一个简单的

Hello World 文本。该模板包含两个组件：div

和 text，同时演示了数据绑定的使用方式。 

List Feature Ability 

使用 JavaScript 语言开发，用于 Smart Vision

设备的 Feature Ability 模板，包含一个可滑动

的列表。此模板包含 4 个组件：list、list-

item、text、div，同时演示了 for 指令进行列

表渲染的方式。 
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3.3 创建一个新的工程 

当开始开发一个 HarmonyOS 应用时，首先需要根据工程创建向导，创建一个新的工程，

工具会自动生成对应的代码和资源模板。 

如果创建的工程包含 JS 语言，请确保已经下载了 JS SDK 包，具体可参考下载

HarmonyOS SDK。 

说明 

在运行 DevEco Studio 工程时，建议每一个运行窗口有 2GB 以上的可用内存空间。 

3.3.1 创建和配置新工程 

1. 通过如下两种方式，打开工程创建向导界面。 

o 如果当前未打开任何工程，可以在 DevEco Studio 的欢迎页，选择 Create HarmonyOS Project 开始

创建一个新工程。 

o 如果已经打开了工程，可以在菜单栏选择 File > New > New Project 来创建一个新工程。 

2. 根据工程创建向导，选择需要进行开发的设备类型，然后选择对应的 Ability 模板。 
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3. 点击 Next，进入到工程配置阶段，需要根据向导配置工程的基本信息。 

Project name：工程的名称，可以自定义。 

Package name：软件包名称，默认情况下，应用 ID 也会使用该名称，应用发布时，应用 ID 需要唯

一。 

Save location：工程文件本地存储路径。 

Compatible SDK：兼容的 SDK 版本。 

4. 点击 Finish，工具会自动生成示例代码和相关资源，等待工程创建完成。 

3.3.2 导入现有工程 

打开现有工程时请注意，DevEco Studio 配套的 SDK 版本和编译构建插件存在版本依赖

关系，如需对已有工程进行适配（比如适配 SDK 版本、编译构建插件版本），请按照下表

的配套关系进行适配。 

DevEco Studio 版本 兼容的 SDK 版本 兼容的编译构建插件版本 

V2.0.12.201 

API Version 4（2.1.0.5） 2.4.0.1 

API Version 3（2.0.1.93） 2.4.0.1、2.0.0.7、2.0.0.6 

V2.0.10.201 及以前历史版本 API Version 3（2.0.1.93） 2.4.0.1、2.0.0.7、2.0.0.6 

打开现有工程时请注意，待导入的工程文件存储路径不能包含中文字符和空格。打开现有

工程包括如下两种方式： 

• 如果当前未打开任何工程，可以在 DevEco Studio 的欢迎页，选择 Open 

Project 打开现有工程。 

• 如果已经打开了工程，可以在菜单栏选择 File > Open 来打开现有工程。 

说明 

如果打开的是以前旧的 DevEco Studio 创建的工程，DevEco Studio 会提示您是否需要将编译构建插件

更新至最新版本，如 2.4.0.1，点击 Update，DevEco Studio 会自动将编译构建插件修改为最新版本。

同时，您还需要手动将 gradle > wrapper > gradle-wrapper.properties 中的 Gradle 版本修改为编

https://developer.harmonyos.com/cn/docs/documentation/doc-guides/build_config-0000001052902431#ZH-CN_TOPIC_0000001057215890__table715443819406
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译构建插件配套的 Gradle 版本，如 2.4.0.1 插件配套的 Gradle 版本为 6.3（打开历史工程同步错误如何

处理？）。 

打开现有工程时，DevEco Studio 会提醒您可以选择在新的窗口打开工程，或

者选择在当前窗口打开工程。 

 

3.4 在工程中添加 Module 

Module 是 HarmonyOS 应用的基本功能单元，包含了源代码、资源文件、第三方库及应

用清单文件，每一个 Module 都可以独立进行编译和运行。一个 HarmonyOS 应用通常会

包含一个或多个 Module，因此，可以在工程中，创建多个 Module，每个 Module 分为

Ability 和 Library（HarmonyOS Library 和 Java Library）两种类型。 

如 HarmonyOS 工程介绍，在一个 APP 中，对于同一类型设备有且只有一个 Entry 

Module，其余 Module 的类型均为 Feature。因此，在创建一个类型为 Ability 的

Module 时，遵循如下原则： 

• 若新增 Module 的设备类型为已有设备时，则 Module 的类型将自动设置为“Feature”。 

• 若新增 Module 的设备类型为当前还没有创建 Module，则 Module 的类型将自动设置为“Entry”。 

3.4.1 新增 Module 

1. 通过如下两种方法，在工程中添加新的 Module。 

o 方法 1：鼠标移到工程目录顶部，点击鼠标右键，选择 New>Module，开始创建新的 Module。 

o 方法 2：在菜单栏选择 File > New > Module，开始创建新的 Module。 

2. 在 New Project Module 界面中，选择 Module 对应的设备类型和模板。 

https://developer.harmonyos.com/cn/docs/documentation/doc-guides/build_config-0000001052902431#ZH-CN_TOPIC_0000001057215890__table715443819406
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3. 点击 Next，在 Module 配置页面，设置新增 Module 的基本信息。 

o Module 类型为 Ability 或者 HarmonyOS Library 时，请根据如下内容进行设置，然后点击 Next。 

▪ Application/Library name：新增 Module 所属的类名称。 

▪ Module name：新增模块的名称。 

▪ Module Type：仅 Module 类型为 Ability 时存在，工具自动根据设备类型下的模块进行设置。 

▪ Package name：软件包名称，可以点击 Edit 修改默认包名称，需全局唯一。 

▪ Compatible SDK：兼容的 SDK 版本。 
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o Module 类型为 Java Library 时，请根据如下内容进行设置，然后点击 Finish 完成创建。 

▪ Library Name：Java Library 类名称。 

▪ Java package name：软件包名称，可以点击 Edit 修改默认包名称，需全局唯一。 

▪ Java class name：class 文件名称。 

▪ Create.gitignore file：是否自动创建.gitignore 文件，勾选表示创建。 
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4. 设置新增 Ability 或 HarmonyOS Library 的 Page Name。 

若该 Module 类型为 Ability，需要设置 Visible 参数，表示该 Ability 是否可以被其它应

用所调用。 

o 勾选（true）：可以被其它应用调用。 

o 不勾选（false）：不能被其它应用调用。 

5. 点击 Finish，等待创建完成后，可以在工程目录中查看和编辑新增的 Module。 

3.4.2 删除 Module 

为防止开发者在删除 Module 的过程中，误将其它的模块删除，DevEco Studio 提供统一

的模块管理功能，需要先在模块管理中，移除对应的模块后，才允许删除。 

1. 在菜单栏中选择 File > Project Structure > Modules，选择需要删除的 Module，点击按钮，并在弹

出的对话框中点击 Yes。 
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2. 在工程目录中选中该模块，点击鼠标右键，选中 Delete，并在弹出的对话框中点击 Delete。 

 

3.5 创建 HarmonyOS 库 

HarmonyOS 库（HarmonyOS Archive，简称 HAR）可以提供应用构建所需

的一切内容，包括源代码、资源文件、HarmonyOS 配置文件以及第三方库。

HAR 不同于 HAP，HAR 不能独立安装运行在设备上，只能作为应用模块的依

赖项被引用。 
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3.5.1 创建库模块 

在 DevEco Studio 中，可以通过如下方式创建新的库模块。 

1. 通过如下两种方法，在工程中添加新的 HarmonyOS Library 模块。 

• 方法 1：鼠标移到工程目录顶部，点击鼠标右键，选择 New>Module。 

• 方法 2：在菜单栏选择 File > New > Module。 

2. 在 New Module 界面中，Device 选择 Phone 或 Tablet 或 Car 或 TV 或

Wearable 设备，Template 选择 HarmonyOS Library，并点击 Next。 

 

3. 在 Configure the New Module 界面中，设置新添加的模块信息，设置完成

后，点击 Finish 完成创建。 

• Application/Library name：新增 Module 所属的类名称。 

• Module name：新增模块的名称。 
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• Package name：软件包名称，可以点击 Edit 修改默认包名称，需全局唯

一。 

• Compatible SDK：兼容的 SDK 版本。 

4. 等待 Gradle 同步完成后，会在工程目录中生成对应的库模块。 

3.5.2 将库模块编译为 HAR 

利用 Gradle 可以将 HarmonyOS Library 库模块构建为 HAR 包，以便在工程中引用 HAR

或者将 HAR 包提供给其它开发者进行调用。构建 HAR 包的方法如下： 

在 Gradle 构建任务中，双击 PackageDebugHar 或 PackageReleaseHar 任务，构建

Debug 类型或 Release 类型的 HAR。 
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待构建任务完成后，可以在工程目录中的 moduleName > bulid > 

outputs > har 目录中，获取生成的 HAR 包。 

 

3.5.3 发布 Har 包到 Maven 仓 

借助 Gradle 提供的 Maven-publish 插件，可以将 Har 包发布到本地或远程 Maven 仓。 

1. 在工程根目录下，点击鼠标右键 New > File，创建一个以“.gradle”结尾的文

件，如 upload.gradle。 

2. 在创建的 upload.gradle 文件中，添加如下示例代码。如下示例代码为发布 HAR

包到 Maven 仓的最小集，请根据实际发布信息进行修改。 

1. apply plugin: 'maven-publish' 

2.   

3. def DEFAULT_POM_NAME='myLibrary' 

4. def DEFAULT_POM_VERSION='1.0.1'  //har包版本信息 

5. def DEFAULT_POM_ARTIFACT_ID="harTest"  //har包 ID 

6. def DEFAULT_POM_GROUP_ID='com.huawei.har'  //项目组 ID 
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7. def DEFAULT_POM_PACKAGING='har'  //包类型，固定为 har 

8. def DEFAULT_POM_DESCRIPTION='myLib for harmonyos' 

9. def MAVEN_USERNAME='admin'   //远程 Maven仓的用户名 

10. def MAVEN_PASSWORD='******'  //远程 Maven仓的密码 

11. def LOCAL_MAVEN_REPOSITORY_URL='D:/01.localMaven/'  //本地 Maven仓地址 

12. def REMOTE_MAVEN_REPOSITORY_URL='http:// '  //远程 Maven仓地址 

13.   

14. afterEvaluate { project -> 

15.     DEFAULT_POM_ARTIFACT_ID = project.name 

16.     publishing { 

17.         publications { 

18.             maven(MavenPublication) { 

19.                 from components.debug  //指定发布的 har包类型为 debug或

release 

20.                 group = DEFAULT_POM_GROUP_ID 

21.                 artifactId = DEFAULT_POM_ARTIFACT_ID 

22.                 version = DEFAULT_POM_VERSION 

23.                 pom { 

24.                     name = DEFAULT_POM_NAME 

25.                     description = DEFAULT_POM_DESCRIPTION 

26.                     packaging = DEFAULT_POM_PACKAGING 

27.                 } 

28.             } 

29.         } 

30.         repositories { 

31.             maven { 

32.                 url = LOCAL_MAVEN_REPOSITORY_URL  //发布到本地 Maven仓 

33.                 //发布到远程 Maven仓的地址以及 Maven 仓的帐号和密码 

34.                 /*url = REMOTE_MAVEN_REPOSITORY_URL 

35.                  credentials { 

36.                     username MAVEN_USERNAME 

37.                     password MAVEN_PASSWORD 

38.                }*/ 

39.             } 

40.         } 

41.     } 

42. } 
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3. 在 Har 模块的 build.gradle 中，添加 HAR 发布脚本。添加完成后，请点击 Sync 

Now 进行同步。 

1. apply from:'../upload.gradle' 

4. 同步完成后，会在 Gradle 任务中增加 publishing 的任务列表。 

 

5. 双击执行 publishMavenPublicationToMavenRepository 任务，将 HAR 包发

布到指定的 Maven 地址。 
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6. 本示例是以发布到本地 Maven 地址为例，发布结果如下图所示。 
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3.5.4 为应用模块添加依赖 

在应用模块中调用 HAR，常用的添加依赖的方式包括如下两种。 

1. 调用同一个工程中的 HAR：HAR 包和应用模块在同一个工程，打开应用模块的

build.gradle 文件，在 dependencies 闭包中，添加如下代码。添加完成后，请

点击 Sync Now 同步工程。 

1. dependencies { 

2.     implementation project(":mylibrary") 

3. } 

2. 调用 Maven 仓中的 HAR：无论 Har 包是本地 Maven 仓还是远程 Maven 仓，均

可以采用如下方式添加依赖。 

a. 在工程的 build.gradle 的 allprojects 闭包中，添加 HAR 所在的 Maven

仓地址。 

1. repositories { 

2.         maven { 

3.             url 'file://D:/01.localMaven/'  //添加 Maven仓地址，

可以是本地 Maven地址，也可以是远程 Maven地址 

4.         } 

5.     } 

b. 在应用模块的 build.gradle 的中，dependencies 闭包中，添加如下代码。 

1. dependencies { 

2.     implementation 'com.huawei.har:mylibrary:1.0.1' 

3. } 

c. 添加完成后，请点击 Sync Now 同步工程。 
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4 代码编辑 
 

4.1 编辑器使用技巧 

DevEco Studio 支持多种语言进行 HarmonyOS 应用的开发，包括 Java、JS 和 C/C++。

在编写应用阶段，您可以通过掌握各种代码编写的各种常用技巧，来提升编码效率。 

4.1.1 代码高亮 

支持对代码关键字、运算符、字符串、类名称、接口名、枚举值等进行高亮颜色显示，可

以在菜单栏打开 File > Settings（或快捷键 Ctrl+Alt+S）面板，在 Editor > Color 

Scheme 自定义各语言高亮显示颜色。 

同时还可以动态的对变量名和参数名进行语义高亮，默认情况下为关闭状态，可以在菜单

栏打开 File > Settings（或快捷键 Ctrl+Alt+S）面板，在 Editor > Color Scheme > 

Language Defaults > Semantic highlighting 中，打开语义高亮开关。 
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4.1.2 代码智能补齐 

编辑器工具会分析上下文并理解项目内容，并根据输入的内容，提示可补齐的类，方法，

字段和关键字的名称等。 
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4.1.3 代码错误检查 

如果输入的语法不符合编码规范，或者出现拼写错误，编辑器会实时的进行代码分析，并

在代码中突出显示错误或警告，并给出对应的修改建议。 

 

4.1.4 代码自动跳转 

在编辑器中，可以按住 Ctrl 键，鼠标点击代码中的类、方法、参数、变量等名称，可以自

动跳转到定义处。 
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4.1.5 代码格式化 

支持对选定范围的代码或者当前整个文件进行代码格式化操作，可以很好的提升代码的美

观度和可读性。 

• 使用快捷键 Ctrl + Alt + L 可以快速对选定范围的代码进行格式化。 

• 使用快捷件 Ctrl + Alt + Shift + L 可以快速对当前整个文件进行格式化。 

如果在进行格式化时，对于部分代码片段不需要进行自动的格式化处理，可以通过如下方

式进行设置： 

1. 首先，在 File>Settings>Editor>Code Style，点击“Formatter Control”，勾选“Enable 

formatter markers in comments”。 

2. 其次，在 Java 或 C/C++代码中，对不需要进行格式化操作的代码块前增加“//@formatter:off”，对不

格式化代码块的最后增加“//@formatter:on”，即表示对该范围的代码块不需要进行格式化操作。 

  

 

4.1.6 代码折叠 

支持对代码块的快速折叠和展开，可以使用快捷键 Ctrl + NumPad+ 快速展开已折叠的

代码；使用快捷键 Ctrl + NumPad-折叠已展开的代码块。 
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4.1.7 代码快速注释 

支持对选择的代码块进行快速注释，使用快捷键 Ctrl+/快速进行注释。对于已注释的代码

快，再次使用快捷键 Ctrl+/取消注释。 
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4.1.8 代码结构树 

支持快速查看代码文档的结构树，包括全局变量和函数，类成员变量和方法等，并可以跳

转到对应代码行。可使用快捷键 Alt + 7 / Ctrl + F12 快速打开代码结构树。 

 

4.1.9 代码查找 

通过对符号、类或文件的即时导航来查找代码。检查调用或类型层次结构，轻松地搜索工

程里的所有内容。通过使用连续按压两次 Shift 快捷键，打开代码查找界面。 
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4.1.10 查看 Java 接口文档 

在 Java 代码选中 HarmonyOS API 或选中 Java 类时，使用快捷键 Ctrl+Q，在弹出的

“Documentation”最下方，会显示相应文档的链接。 

例如：图示红框中的“‘AbilityPackage’on D” 
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点击文档的链接，比如：“‘AbilityPackage’on D”，将打开详细说明文档。 
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4.2 在模块中添加 Ability 

Ability 是应用所具备的能力的抽象，一个 Module 可以包含一个或多个 Ability。Ability

分为两种类型：FA（Feature Ability）和 PA（Particle Ability），DevEco Studio 支持

创建的 Ability 模板和应用场景如下表所示。 

Ability 类型 Ability 模板 使用场景 

Particle Ability 

Empty Data Ability 

Data Ability 有助于应用管理其自身和其他应

用所存储数据的访问，并提供与其他应用共

享数据的方法。Data 既可用于同设备不同应

用的数据共享，也支持跨设备之间不同应用

的数据共享。 

Empty Service Ability 

Service Ability 可在后台长时间运行而不提

供用户交互界面。Service 可由其他应用或

Ability 启动，即使用户切换到其他应用，

Service 仍将在后台继续运行。 

Feature Ability 

Empty Feature 

Ability(JS) 
用 JS 和 Java 编写带 UI 界面的空模板。 

Empty Feature 

Ability(Java) 
用 Java 和 xml 编写带 UI 界面的空模板。 

List Feature Ability(JS) 
用 JS 和 Java 编写带 UI 界面的目录列表模

板。 

Tab Feature Ability(JS) 用 JS 和 Java 编写带 UI 界面的表单模板。 

4.2.1 创建 Particle Ability 

1. 选中对应的模块，点击鼠标右键，选择 New > Ability ，然后选择 Empty Data Ability 或者 Empty 

Service Ability。 
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2. 根据选择的 Ability 模板，设置 Ability 的基本信息。 

o Empty Data Ability 基本信息设置： 

▪ Data Name：Data Ability 类名称。 

▪ Visible：表示该 Ability 是否可以被其它应用所调用，勾选上则表示允许被调用。 

▪ Package name：新增 Ability 对应的包名称。 

o Empty Service Ability 基本信息设置： 

▪ Service Name：Service Ability 类名称。 

▪ Visible：表示该 Ability 是否可以被其它应用所调用，勾选上则表示允许被调用。 

▪ Package name：新增 Ability 对应的包名称。 

▪ Enable background mode：指定用于满足特定类型的后台服务，可以将多个后台服务类型分配给特定

服务。各服务与 config.json 文件的映射关系如下表所示。 

Background modes 对应 config.json 字段名称 描述 

Data upload/download, 

backup/restore 
data-transfer 

通过网络/对端设备进行数据

下载，备份分享，传输等业务 

Audio playback audio-playback 音频输出业务 

Audio recording audio-recording 音频输入业务 

Picture-in-picture picture-in-picture 画中画，小窗口播放视频业务 
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Background modes 对应 config.json 字段名称 描述 

Voice/video call over IP voip 音视频电话、VOIP 业务 

Location update location 定位，导航业务 

Bluetooth communication bluetooth-interaction 
蓝牙扫描、连接、传输业务

（穿戴） 

Wifi communication wifi-interaction 
WLAN 扫描、连接、传输业

务（多屏，克隆） 

Screen recording, 

screenshot 
screen-fetch 录屏，截屏业务 

3. 点击 Finish 完成 Ability 的创建，可以在工程目录对应的模块中查看和编辑 Ability。 

4.2.2 创建 Feature Ability 

1. 选中对应的模块，点击鼠标右键，选择 New > Ability ，然后选择对应的 Feature Ability 模板。 

  

 

2. 根据选择的 Ability 模板，设置 Feature Ability 的基本信息。 

o Page Name：Feature Ability 类名称。 
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o Launcher Ability：表示该 Ability 在终端桌面上是否有启动图标，一个 HAP 可以有多个启动图标，来

启动不同的 FA。 

o Visible：表示该 Ability 是否可以被其它应用所调用，勾选上则表示允许被调用。 

o JS Component Name：JS 组件名称，只有涉及 JS 开发语言时才需要设置。 

o Package name：新增 Ability 对应的包名称。 

3. 点击 Finish 完成 Ability 的创建，可以在工程目录对应的模块中查看和编辑 Ability。 

4.3 添加 JS Component 和 JS Page 

在支持 JS 语言的工程中，支持添加新的 JS Component 和 JS Page，在此之前，需要了

解它们的基本概念。 

• JS Component：在 JS 工程中，可以存在多个 JS Component（例如 js 目录下的 default 文件夹就是一

个 JS Component），一个 JS FA 对应一个 JS Component，可以独立编译、运行和调试。 

说明 

轻量级智能穿戴对应的 JS 工程，只存在一个 JS FA，因此，轻量级智能穿戴的 JS 工程不允许创建新的 JS 

Component。 

• JS Page：Page 是表示 JS FA 的一个前台页面，由 JS、HML 和 CSS 文件组成，是 Component 的最基

本单元，构成了 JS FA 的每一个界面。 

4.3.1 添加 JS Component 

在 JS 工程目录中，选中 js 文件夹，然后点击鼠标右键，选择 New > JS Component，

输入 JS Component Name，点击 Finish 完成添加。 
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4.3.2 添加 JS Page 

在 JS 工程目录中，选择需要添加 Page 的 Component 下的 pages 文件夹，然后点击鼠

标右键，选择 New > JS Page，输入 JS Page Name，点击 Finish 完成添加。 
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4.4 定义 HarmonyOS IDL 接口 

4.4.1 HarmonyOS IDL 简介 

HarmonyOS Interface Definition Language（简称 HarmonyOS IDL）是 HarmonyOS

的接口描述语言。HarmonyOS IDL 与其他接口语言类似，通过 HarmonyOS IDL 定义客

户端与服务端均认可的编程接口，可以实现在二者间的跨进程通信（IPC，Inter-Process 

Communication）。跨进程通信意味着我们可以在一个进程访问另一个进程的数据，或

调用另一个进程的方法。 

通常我们把应用接口提供方（供调用）称为服务端，调用方称为客户端。客户端通过绑定

服务端的 Ability 来与之进行交互，类似于绑定服务。关于 DevEco Studio 接口语言的详

细描述请参考 HarmonyOS IDL 接口使用规范。 

说明 

只能使用 Java 或 C++语言构建.idl 文件，因此仅 Java、Java+JS、C/C++工程支持 IDL。 

4.4.2 创建.idl 文件 

1. 在已经创建/打开的 HarmonyOS 工程中，选择 module 目录或其子目录，点击鼠标右

键，选择 New>Idl File。 
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2. 创建 IDL File。可以直接输入 IDL 接口名称，也可以通过包名格式定义 idl 接口名称。两

种方式的差异仅在于.idl 文件的文件目录结构。 

o 按名称创建，创建 IDL File 时，输入接口名称，直接点击 OK。 

   

DevEco Studio 在相应“module”的 src>main 路径下生成 idl 文件夹，并按照对应模

块的包名生成同样的目录结构及 IDL 文件。 
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o 按包名创建，自定义.idl 文件存储路径和接口名称。创建“IDL File”时，按照包名创建

IDL 文件。包名利用“.”作为分隔符，如输入“com.huawei.test.MyIdlInterface”。 

   

 

DevEco Studio 在相应“module”的 src>main 路径下生成 idl 文件夹，并按照输入的

包名生成相应目录结构及 IDL 文件。可以在此路径继续新增 IDL 文件。 
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3. 点击工程右边栏的 Gradle，在 Tasks > ohos 中选择 compileDebugIdl 或

compileReleaseIdl，对模块下的 IDL 文件进行编译。 
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4. 编译完成后，在 build > generated > source > Idl> {Package Name}目录下，生成

对应的接口类、桩类和代理类，如下图所示。 
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4.4.3 实现 HarmonyOS IDL 接口 

开发者可以使用 Java 或 C++编程语言构建.idl 文件，关于 HarmonyOS IDL 接口的实现

请参考 IDL 开发指南。 

4.5 使用预览器查看应用效果 

DevEco Studio 仅针对 Lite Wearable 提供预览器的功能。预览器支持代码热加载，在开

发应用的同时，只要将开发的代码保存到源码中，即可在预览器中实时查看应用效果，方

便开发者随时调整代码。 

在使用预览器查看应用界面的 UI 效果前，需要确保 HarmonyOS SDK > SDK Tools

中，已下载 Previewer 资源，详情请参考下载 HarmonyOS SDK。 

 

打开预览器有两种方式，显示效果如下图所示。 
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• 通过菜单栏，点击 View>Tool Windows>Previewer，打开预览器。 

• 在编辑窗口右上角的侧边工具栏，点击 Previewer，打开预览器。 

•  

• 预览器还提供 Lite Wearable 的场景化数据注入功能，如点亮/关闭屏幕，调节屏

幕亮度，向应用注入步数、心率、经纬度等信息，可以在开发阶段模拟真实的使用

场景，便于开发者验证应用使用体验。 

 

4.6 将 SVG 文件转换为 XML 文件 

SVG（Scalable Vector Graphics）可缩放矢量图形，是一种图像文件格式。目前由于

HarmonyOS 图形渲染引擎不支持 SVG 格式图片的渲染，开发者需要将 SVG 格式的图片

文件转为为 XML 格式的文件，然后在布局文件中引用转换后的 XML 文件。这样，就可以

在模拟器/预览器或者设备上运行应用时，正常的渲染该图像文件。转换方法如下： 

1. 选中应用模块，点击鼠标右键，选择 New>Svg To Xml。 
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2. 选择需要转换的 svg 文件，并命名，点击 OK 按钮开始转换。 

  

 

 

3. 转换成功后，可以在 resources > base > graphic 文件下找到转换后的 xml 文件，并在布局文件中，

引用该 xml 文件名即可完成对图标文件的引 
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4.7 代码安全检查 

DevEco Studio 针对 Java 语言代码进行安全检查，扫描代码安全问题，并根据扫描结果

提示进行修改，有助于开发提高代码的健壮性。常见的代码安全问题包括如下几类： 

• 凭据管理 

• 认证问题和会话管理 

• 权限控制 

• 加密问题 

• 信息泄露 

• 完整性保护 

• 隐私保护 

• 不正确输入校验 

• 安全编译 

检查方法：鼠标选中已打开的代码编辑文件、或者鼠标点击选中文件或文件夹，或者按

Ctrl+鼠标点击选中多个文件，然后点击鼠标右键，选中 Code Check。 
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扫描完成后： 

• 双击某个扫描结果可以跳转到对应代码，可以根据 Detail 的建议进行修改。 

• 如果某个扫描结果不需要修改，可以对该扫描结果进行屏蔽，屏蔽后再执行 Code Check 将不再显示该

扫描结果。 

o 在扫描结果处，点击鼠标右键，选择 Block False Positives 可以屏蔽该行的安全检查。 

o 如需恢复安全检查屏蔽的错误信息，可以在.idea>shield_config.xml 中删除某条屏蔽信息，或者直接

删除.idea>shield_config.xml 文件来删除全部屏蔽信息。 
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5 编译构建 

5.1 编译构建概述 

编译构建是将 HarmonyOS 应用的源代码、资源、第三方库等打包生成 HAP 或者 APP 的

过程。其中，HAP 可以直接运行在真机设备或者模拟器中；APP 则是用于应用上架到华为

应用市场。HAP 和 APP 的关系说明请参考 HarmonyOS 工程介绍。 

为了确保 HarmonyOS 应用的完整性，HarmonyOS 通过数字证书和授权文件来对应用进

行管控，只有签名过的 HAP 才允许安装到设备上进行运行（如果不带签名信息，仅可以

运行在模拟器中）；同时，上架到华为应用市场的 APP 也必须通过签名才允许上架。因

此，为了保证应用能够发布和安装到设备上， 需要提前申请相应的证书与 Profile 文件，

详情请参考申请证书和 Profile。 

申请证书和 Profile 文件时，用于调试和上架的证书与授权文件不能交叉使用： 

• 应用调试证书与应用调试 Profile 文件、应用发布证书与应用发布 Profile 文件具有匹配关系，必须成对使

用，不可交叉使用。 

• 应用调试证书与应用调试 Profile 文件必须应用于调试场景，用于发布场景将导致应用发布审核不通过；

应用发布证书与应用发布 Profile 文件必须应用于发布场景，用于调试场景将导致应用无法安装。 

 

5.2 编译构建前配置 

在进行 HarmonyOS 应用的编译构建前，需要对工程和编译构建的 Module 进行设置，请

根据实际情况进行修改。 
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• build.gradle：HarmonyOS 应用依赖 gradle 进行构建，需要通过 build.gradle 来对工程编译构建参数

进行设置。build.gradle 分为工程级和模块级两种类型，其中工程根目录下的工程级 build.gradle 用于

工程的全局设置，各模块下的 build.gradle 只对本模块生效。 

• config.json：应用清单文件，用于描述应用的全局配置信息、在具体设备上的配置信息和 HAP 的配置信

息。 

5.2.1 工程级 build.gradle 

• apply plugin：在工程级 Gradle 中引入打包 app 的插件，不需要修改。 

1. apply plugin: 'com.huawei.ohos.hap' 

• ohos 闭包：工程配置，包括如下配置项： 

1. compileSdkVersion：依赖的 SDK 版本。 

1. compileSdkVersion 3    //应用编译构建的目标 SDK 版本 

2.      defaultConfig { 

3.          compatibleSdkVersion 3    //应用兼容的最低 SDK 版本 

4.  } 

2. signingConfigs：发布 APP 时的签名信息，在编译构建生成 APP 中进行设置后自动生成。 

• buildscript 闭包：Gradle 脚本执行依赖，包括 Maven 仓地址和插件。 

1. buildscript { 

2.     repositories {    

3.         maven { 

4.             url 'https://mirrors.huaweicloud.com/repository/maven/' 

5.         } 

6.         maven { 

7.             url 'https://developer.huawei.com/repo/' 

8.         }       

9.         jcenter() 

10.     } 

11.        dependencies { 

12.          classpath 'com.huawei.ohos:hap:2.0.0.6' 

13.     } 

14. } 

• allprojects 闭包：工程自身所需要的依赖，比如引用第三方库的 Maven 仓库和依赖包。 

1. allprojects { 

2.     repositories { 

3.        maven { 
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4.             url 'https://mirrors.huaweicloud.com/repository/maven/' 

5.        } 

6.        maven { 

7.             url 'https://developer.huawei.com/repo/' 

8.        }       

9.        jcenter() 

10.     } 

11. } 

5.2.2 模块级 build.gradle 

• apply plugin：在模块级 Gradle 中引入打包 hap 和 library 的插件，无需修改。 

1. apply plugin: 'com.huawei.ohos.hap'   //打包 hap 包的插件 

2. apply plugin: 'com.huawei.ohos.library'    //将 HarmonyOS Library 打包为 har 的插件 

3. apply plugin: 'com.huawei.ohos.java-library'    //将 Java Library 打包为 jar 的插件 

• ohos 闭包：模块配置，包括如下配置项： 

1. compileSdkVersion：依赖的 SDK 版本。 

1. compileSdkVersion 3    //应用编译构建的目标 SDK 版本 

2.      defaultConfig { 

3.          compatibleSdkVersion 3    //应用兼容的最低 SDK 版本 

4.  } 

2. signingConfigs：在编译构建生成 HAP 中进行设置后自动生成。 

3. externalNativeBuild：C/C++编译构建代码设置项。 

1. externalNativeBuild { 

2.     path "src/main/cpp/CMakeLists.txt"   //CMake 配置入口，提供 CMake 构建脚本的相对路径 

3.     arguments "-v"    //传递给 CMake 的可选编译参数 

4.     abiFilters "arm64-v8a"     //用于设置本机的 ABI 编译环境 

5.     cppFlags ""   //设置 C++编译器的可选参数 

4. entryModules：该 Feature 模块关联的 Entry 模块。 

1. entryModules "entry"     

5. mergeJsSrc：跨设备的应用编译构建，是否需要合并 JS 代码。Wearable 和 Lite Wearable 共用一个工

程，如下图所示。当进行编译构建时，将 Wearable/Lite Wearable 目录下的 JS 文件与 pages 目录

（Wearable 和 Lite Wearable 共用的源码）下的 JS 文件进行合并打包。 
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1. mergejssrc true    //合并 JS 代码打包时，请在 ohos 闭包下手动添加，true 表示需要合并 JS 代码，false 表示不需要合并

JS 代码。 

6. annotationEnabled：支持数据库注释。 

1. compileOptions{  

2.          annotationEnabled true   //true 表示支持，false 表示不支持 

• dependencies 闭包：该模块所需的依赖项。 

1. dependencies { 

2.     entryImplementation project(':entry')    //该 Feature 模块依赖的 Entry 模块 

3.     implementation fileTree(dir: 'libs', include: ['*.jar','*.har'])    //该模块依赖的本地库，支持 jar 和 har 包 

4.     testCompile'junit:junit:4.12'    //测试用例框架，无需修改 

5. } 

5.2.3 config.json 配置文件 

HarmonyOS 应用的每个模块下包含一个 config.json 配置文件，在编译构建前，需要对

照检查和修改 config.json 文件，详情请参考 config.json 清单文件介绍。 
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5.3 准备签名文件 

5.3.1 生成密钥和证书请求文件 

HarmonyOS 应用通过数字证书和授权文件来保证应用的完整性，在申请数字证书和

Profile 文件前，需要通过 DevEco Studio 来生成私钥（存放在.p12 文件中）和证书请求

文件（.csr 文件）。同时，也可以使用命令行工具的方式来生成密钥和证书请求文件，用

于构筑工程流水线。 

5.3.1.1 使用 DevEco Studio 生成证书请求文件 

使用 DevEco Studio 生成证书请求文件的方式有以下两种情况： 

• 如果还未生成密钥文件，则可以一键生成密钥和证书请求文件。 

• 如果已有密钥文件，则可以使用已有密钥生成证书请求文件。 

一键生成密钥和证书请求文件 

1. 在主菜单栏点击 Build > Generate Key。 

2. 在 Key Store Path 中，可以点击 Choose Existing 选择已有的密钥库文件；如果没有密钥库文件，点

击 New 进行创建。下面以新创建密钥库文件为例进行说明。 

3. 在 Create Key Store 窗口中，填写密钥库信息后，点击 OK。 

o Key Store Path：选择密钥库文件存储路径。 

o Password：设置密钥库密码，必须由大写字母、小写字母、数字和特殊符号中的两种以上字符的组合，

长度至少为 8 位。请记住该密码，后续签名配置需要使用。 

o Confirm Password：再次输入密钥库密码。 
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4. 在 Generate Key 界面中，继续填写密钥信息后，点击 Generate Key and CSR。 

o Alias：密钥的别名信息，用于标识密钥名称。请记住该别名，后续签名配置需要使用。 

o Password：输入密钥对应的密码，密钥密码需要与密钥库密码保持一致。请记住该密码，后续签名配置

需要使用。 

o Confirm Password：再次输入密钥密码。 

o Validity：证书有效期，建议设置为 25 年及以上，覆盖应用的完整生命周期。 

o Certificate：输入证书基本信息，如组织、城市或地区、国家码等。 

   

5. 在弹出的窗口中，点击 CSR File Path 对应的图标，选择 CSR 文件存储路径。 

   

6. 点击 OK 按钮，创建 CSR 文件成功，工具会同时生成密钥文件（.p12）和证书请求文件（.csr）。 
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使用已有密钥生成证书请求文件 

1. 在主菜单栏点击 Build > Generate Certificate Request File。 

2. 在 Generate CSR 界面，填写证书请求文件生成参数，点击 OK。 

o key Store Path：点击 Choose Existing 选择已有的密钥库文件，后缀格式为.p12。 

o Key Store Password：输入创建密钥时填写的密钥库密码。 

o Key Alias：输入创建密钥时填写的别名信息。 

o Key Password：输入创建密钥时填写的密钥密码。 

o Certificate Path：点击按钮，选择证书请求文件存储路径和名称。 

   

3. 打开证书请求文件存储目录，获取证书请求文件（.csr 文件）。 

5.3.1.2 使用命令行工具生成证书请求文件 

使用 Open JDK 携带的 Keytool 工具生成证书请求文件。 

1. 使用管理员身份运行命令行工具。 
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2. 切换到 keytool 工具所在路径，实际路径请根据安装目录进行修改。 

   

 

3. 执行如下命令，生成密钥文件。例如，生成的密钥名称为 ide_demo_app.p12，存储到 D 盘根目录下。 

1. keytool -genkeypair -alias "ide_demo_app" -keyalg EC -sigalg SHA256withECDSA -dname 

"C=CN,O=HUAWEI,OU=HUAWEI IDE,CN=ide_demo_app"  -keystore d:\\idedemokey.p12 -storetype pkcs12 -

validity 9125 -storepass 123456 -keypass 123456 

生成密钥文件的参数说明如下： 

说明 

请记录下 alias、storepass 和 keypass 的值，后续编译构建生成 HAP 和编译构建生成 APP 会使用到。 

2. alias：密钥的别名信息，用于标识密钥名称。 

3. sigalg：签名算法，固定为 SHA256withECDSA。 

4. dname：按照操作界面提示进行输入。 

▪ C：国家/地区代码，如 CN。 

▪ O：组织名称，如 HUAWEI。 

▪ OU：组织单位名称，如 HUAWEI IDE。 

▪ CN：名字与姓氏，建议与别名一致。 

5. validity：证书有效期，建议设置为 9125（25 年）。 

6. storepass：设置密钥库密码。 

7. keypass：设置密钥的密码，请与 storepass 保持一致。 

4. 执行如下命令，执行后需要输入 storepass 密码，生成证书请求文件，后缀格式为.csr。 
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1. keytool -certreq -alias "ide_demo_app" -keystore d:\\idedemokey.p12 -storetype pkcs12 -file 

d:\\idedemokey.csr 

生成证书请求文件的参数说明如下： 

2. alias：与 3 中输入的 alias 保持一致。 

3. file：生成的证书请求文件名称，后缀为.csr。 

5.3.2 申请证书和 Profile 

目前华为应用市场只支持 Lite Wearable（轻量级智能穿戴）的 HarmonyOS 应用的上

架，因此只支持轻量级智能穿戴设备的证书和 Profile 文件申请。智慧屏、智能穿戴等设

备的证书、Profile 文件的申请，以及对应应用上架功能，敬请期待。 

对于 Lite Wearable 的调试、发布证书和 Profile 的申请，请参考： 

• 申请调试证书和 Profile 

• 申请发布证书和 Profile 

说明 

在申请证书和 Profile 前，请根据生成密钥和证书请求文件准备好证书请求文件。 

5.4 编译构建生成 HAP 

HAP 可以直接在模拟器或者真机设备上运行，用于 HarmonyOS 应用开发阶段的调试和

查看运行效果。HAP 按构建类型和是否签名可以分为以下四种形态： 

• 构建类型为 Debug 的 HAP（带调试签名信息）：携带调试签名信息，具备单步调试等调试手段的

HAP，用于开发者在真机或者模拟器中进行应用调试。 

• 构建类型为 Debug 的 HAP（不带签名）：不带调试签名信息，具备单步调试等调试手段的 HAP，仅能

运行在模拟器中。 

• 构建类型为 Release 的 HAP（带调试签名信息）：携带调试签名信息，不具备调试能力的 HAP，用于开

发者在真机或者模拟器中查看和验证应用运行效果。相对于 Debug 类型的 HAP 包，体积更小，运行效

果与用户实际体验一致。 

• 构建类型为 Release 的 HAP（不带签名）：不带调试签名信息，不具备调试能力的 HAP，仅能运行在模

拟器中查看和验证应用运行效果。相对于 Debug 类型的 HAP 包，体积更小，运行效果与用户实际体验

一致。 

https://developer.harmonyos.com/cn/docs/documentation/doc-guides/create_csr-0000001053702411#ZH-CN_TOPIC_0000001053702411__li114526518483
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根据 HarmonyOS 工程介绍，一个 HarmonyOS 工程下可以存在多个 Module，在编译

构建时，可以选择对单个 Module 进行编译构建；也可以对整个工程进行编译构建，同时

生成多个 HAP。 

5.4.1 前提条件 

• 已完成 build.gradle 和 config.json 的设置，详情请参考编译构建前配置。 

• 已完成调试证书和 Profile 文件的申请，详情请参考申请证书和 Profile。 

5.4.2 构建类型为 Debug 的 HAP（带调试签名信息） 

如果一个工程目录下存在多个 Module，当对单个 Module 进行构建时，只需要对指定的

Module 进行签名；如果对整个工程进行构建，则需要对所有的 Module 进行签名。 

1. 打开 File>Project Structure，在 Modules>entry（模块名称）>Signing Configs > debug 窗口

中，配置指定模块的调试签名信息。 

o Store File：选择密钥库文件，文件后缀为.p12。 

o Store Password：输入密钥库密码。 

o Key Alias：输入密钥的别名信息。 

o Key Password：输入密钥的密码。 

o SignAlg：签名算法，固定为 SHA256withECDSA。 

o Profile File：选择申请的调试 Profile 文件，文件后缀为.p7b。 

o Certpath File：选择申请的调试数字证书文件，文件后缀为.cer。 
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2. 在主菜单栏，点击 Build > Build APP(s)/Hap(s) > Build Debug Hap(s)，生成已签名的 Debug 

HAP。 
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5.4.3 构建类型为 Debug 的 HAP（不带签名） 

对于构建类型为 Debug 的 HAP，如果没有配置签名参数，则默认不对 HAP 进行签名，

该方式生成的 HAP 仅能运行在模拟器上。 

在主菜单栏，点击 Build > Build APP(s)/Hap(s) > Build Debug Hap(s)，生成不带签

名的调试 Debug HAP。 

5.4.4 构建类型为 Release 的 HAP（带调试签名信息） 

如果一个工程目录下存在多个 Module，当对单个 Module 进行构建时，只需要对指定的

Module 进行签名；如果对整个工程进行构建，则需要对所有的 Module 进行签名。 

1. 打开 File>Project Structure，在 Modules>entry（模块名称）>Signing Configs > release 窗口

中 ，配置指定模块的调试签名信息。 

o Store File：选择密钥库文件，文件后缀为.p12。 

o Store Password：输入密钥库密码。 

o Key Alias：输入密钥的别名信息。 

o Key Password：输入密钥的密码。 

o SignAlg：签名算法，固定为 SHA256withECDSA。 

o Profile File：选择申请的调试 Profile 文件，文件后缀为.p7b。 

o Certpath File：选择申请的调试数字证书文件，文件后缀为.cer。 
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2. 在主菜单栏，点击 Build > Build APP(s)/Hap(s) > Build Release Hap(s)，生成已签名的 Release 

HAP。 
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5.4.5 构建类型为 Release 的 HAP（不带签名） 

对于构建类型为 Release 的 HAP，如果没有配置签名参数，则默认不对 HAP 进行签名，

该方式生成的 HAP 仅能运行在模拟器上。 

在主菜单栏，点击 Build > Build APP(s)/Hap(s) > Build Release Hap(s)，生成不带

签名的调试 Release HAP。 
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6 应用运行 

6.1 使用模拟器运行应用 

DevEco Studio 提供模拟器供开发者运行和调试 HarmonyOS 应用，对于 Phone、

Tablet、Car、TV 和 Wearable 可以使用 Remote Emulator 运行应用，对于 Lite 

Wearable 和 Smart Vision 可以使用 Simulator 运行应用。 

6.1.1 使用 Remote Emulator 运行应用 

DevEco Studio 提供的 Remote Emulator 可以运行和调试 Phone、Tablet、Car、TV

和 Wearable 设备的 HarmonyOS 应用。在 Remote Emulator 上运行应用兼容签名与不

签名两种类型的 HAP。 

Remote Emulator 每次使用时长为 1 小时，到期后会自动释放资源，请及时完成

HarmonyOS 应用的调试。如果 Remote Emulator 到期释放后，您可以重新申请资

源。 

1. 在 DevEco Studio 菜单栏，点击 Tools > HVD Manager。首次使用 Remote 

Emulator，需下载相关资源，请点击 OK，等待资源下载完成后，请重新点击

Tools > HVD Manager。 
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2. 在浏览器中弹出华为开发者联盟帐号登录界面，请输入已实名认证的华为开发者联

盟帐号的用户名和密码进行登录。 

3. 登录后，请点击界面的允许按钮进行授权。 

 

4. 点击已经连接的 Remote Emulator 设备运行按钮，启动远程模拟设备（同一时间

只能启动一个设备）。 
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5. 点击 DevEco Studio 的 Run > Run'模块名称'或，或使用默认快捷键 Shift+F10

（Mac 为 Control+R）。 

6. 在弹出的 Select Deployment Target 界面选择已启动的 Remote Emulator 设

备，点击 OK 按钮。 

 

7. DevEco Studio 会启动应用的编译构建，完成后应用即可运行在 Remote 

Emulator 上。 
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Remote Emulator 侧边栏按钮作用： 

：释放当前正在使用的 Remote Emulator，单次使用时长 1 小时。 

：设置 Remote Emulator 设备分辨率。 

：返回设备主界面。 

：后退按钮。 

6.1.2 在 Simulator 中运行应用 

DevEco Studio 提供的 Simulator 可以运行和调试 Lite Wearable 和 Smart Vision 设备

的 HarmonyOS 应用。在 Simlutor 上运行应用兼容签名与不签名两种类型的 HAP。 

1. 点击 DevEco Studio 的 Run > Run'模块名称'或，或使用默认快捷键 Shift+F10

（Mac 为 Control+R）。 



文档内容来自鸿蒙官方网站，鸿蒙学堂 hmxt.org 整理 

84 

 

2. 在弹出的 Select Deployment Target 界面的 Available Huawei Lite Devices

设备列表中，选择需要运行的设备，点击 OK 按钮。 

 

3. DevEco Studio 会启动应用的编译构建，完成后应用即可运行在 Simulator 上。 
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6.2 使用真机设备运行应用 

6.2.1 在 Phone 和 Tablet 中运行应用 

在 Phone 和 Tablet 中运行 HarmonyOS 应用的操作方法一致，均采用 USB 的连接方

式。 

前提条件 

• 在 Phone 或者 Tablet 中运行应用，需要提前根据编译构建生成 HAP 章节，打包

带签名信息的 HAP。 

• 在 Phone 或者 Tablet 中，打开“开发者模式”，可在设置 > 关于手机/关于平板

中，连续多次点击“版本号”，直到提示“您正处于开发者模式”即可。 

操作步骤 

1. 使用 USB 方式，将 Phone 或者 Tablet 与 PC 端进行连接。 

2. 在 Phone 或者 Tablet 中，USB 连接方式选择“传输文件”。 

3. 在 Phone 或者 Tablet 中，打开设置 > 系统和更新 > 开发人员选项，打开

“USB 调试”开关。 

4. 在菜单栏中，点击 Run>Run'模块名称'或，或使用默认快捷键 Shift+F10（Mac

为 Control+R）运行应用。 
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5. 在弹出的界面，选择已连接的设备，点击 OK 按钮。 

6. DevEco Studio 启动 HAP 的编译构建和安装。安装成功后，Phone 或者 Tablet

会自动运行安装的 HarmonyOS 应用。 

 

6.2.2 在 Car 中运行应用 

在 Car 中安装和运行 HarmonyOS 应用，采用 USB 连接方式。 

前提条件 

在 Car 中运行应用，需要提前根据编译构建生成 HAP 章节，打包带签名信息的 HAP。 

操作步骤 

1. 使用 USB 方式，连接 Car 和 PC 端。 

2. 在菜单栏中，点击 Run>Run'模块名称'或，或使用默认快捷键 Shift+F10（Mac

为 Control+R）运行应用。 

 

3. 在弹出的界面，选择已连接的 Car 设备，点击 OK 按钮。 
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4. DevEco Studio 启动 HAP 的编译构建和安装。安装成功后，Car 会自动运行安装

的 HarmonyOS 应用。 

6.2.3 在 TV 中运行应用 

在 TV（智慧屏）中安装和运行 HarmonyOS 应用，采用 IP Connect 的连接方式。该连

接方式要求 TV 和 PC 端在同一个网段，建议将 TV 和 PC 连接到同一个 WLAN 下；如果

采用网线连接，需要手动设置 PC 和 TV 的本地 IP 地址。 

前提条件 

• 已将 TV 和 PC 连接到同一网络或设置为同一个网段。 

• 已获取 TV 端的 IP 地址。 

• TV 上 5555 端口为打开状态。 

• 在 TV 中运行应用，需要提前根据编译构建生成 HAP 完成 HAP 的签名配置。 

操作步骤 

1. 在 DevEco Studio 菜单栏中，点击 Tools>IP Connect，输入连接设备的 IP 地址，点击 ，连接正常

后，设备状态为 online。 
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2. 在菜单栏中，点击 Run>Run'模块名称'或 ，或使用默认快捷键 Shift+F10（Mac 为

Control+R）运行应用。 

   

3. 在弹出的界面，选择已连接的 TV 设备，点击 OK 按钮。 

4. DevEco Studio 启动 HAP 的编译构建和安装。安装成功后，TV 会自动运行安装的 HarmonyOS 应用。 

6.2.4 在 Wearable 中运行应用 

在 Wearable 中安装和运行 HarmonyOS 应用，采用 USB 连接方式。 

前提条件 

在 Wearable 中运行应用，需要提前根据编译构建生成 HAP 章节，完成 HAP 的签名配

置。 

操作步骤 

1. 使用 USB 方式，连接 Wearable 和 PC 端。 

2. 在菜单栏中，点击 Run>Run'模块名称'或，或使用默认快捷键 Shift+F10（Mac 为 Control+R）运行

应用。 
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3. 在弹出的界面，选择已连接的 Wearable 设备，点击 OK 按钮。 

4. DevEco Studio 启动 HAP 的编译构建和安装。安装成功后，Wearable 会自动运行安装的 HarmonyOS

应用。 

6.2.5 在 Lite Wearable 中运行应用 

Lite Wearable 的 HarmonyOS 应用安装，依赖华为手机上的运动健康和应用调测助手

APP 辅助进行。 

前提条件 

• 已将运动健康 APP 升级至最新版本。 

• 从华为应用市场安装应用调测助手 APP。 

• 在 Lite Wearable 中运行应用，需要提前根据编译构建生成 HAP 完成 HAP 的签名配置。 

操作步骤 

1. 使用 USB 连接线将手机和电脑进行连接，确保连接状态是正常的。 

2. 手机与电脑使用 USB 连接时，在手机上选择传输文件连接方式。 

3. 在工程目录中的 Build > outputs >hap 中选择生成的 HAP，通过手工拷贝的方式将 HAP 拷贝至手机

中的“/sdcard/haps/”目录。 

说明 

如果在手机存储根目录下没有“haps”文件夹，请手工创建后再拷贝 HAP 到该文件夹下。 

4. 将 Lite Wearable 通过蓝牙与华为手机进行连接。 

1. 进入运动健康 APP，在设备页签中，点击添加设备按钮。 
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2. 进入手表列表中，选择对应的 Lite Wearable 型号。 

3. 点击开始配对，按照界面指引完成 Lite Wearable 与华为手机之间的连接。 

5. 打开应用调测助手 APP，界面会显示已经与华为手机连接的 Lite Wearable。 

说明 

如果 Lite Wearable 与华为手机未连接，请点击应用调测助手 APP 界面的连接设备按钮，手机会自动打

开运动健康 APP 添加 Lite Wearable。 

6. 点击应用调测助手 APP 界面中的安装手表应用按钮，选择需要安装的 HarmonyOS 安装包进行安装。 

7. 安装完成后，点击 Lite Wearable 中的应用图标，运行 HarmonyOS 应用。 

 

 

6.2.1 在 Lite Wearable 中运行应用 

在 Samrt Vision 中安装和运行 HarmonyOS 应用，采用手动将 HAP 拷贝到

Smart Vision 的 sdcard 中再进行安装。 

前提条件 

• 在 Smart Vision 中运行应用，需要提前根据编译构建生成 HAP 章节，完成 HAP

的编译打包。请注意，编译打包时，请选择打包不带签名信息的 HAP。 

• 获取 Smart Vision 应用的安装工具，可从 Hi3516DV300 的 HarmonyOS 源码编

译后的 out\ipcamera_hi3516dv300\dev_tools 下获取。 

• Hi3516DV300 开发板已完成 HarmonyOS 的镜像烧录，并完成镜像的运行，具

体请参考 Hi3516 快速入门。 

操作步骤 

1. 将编译生成的不带签名信息的 HAP 和安装工具（镜像文件生成目录中的

dev_tools 文件夹），拷贝到 sdcard 中，并将 sdcard 插入开发板卡槽。 

2. 将 PC 与开发板进行连接，需要同时连接串口和电源，具体可参考 Hi3516 开发板

介绍。 
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3. 使用串口工具连接开发板，串口工具请自行获取安装。 

4. 连接开发板后，执行如下命令，关闭 HarmonyOS 应用签名校验。 

1. ./sdcard/dev_tools/bin/bm set -s disable 

5. 执行如下命令，安装 HarmonyOS 应用。 

1. ./sdcard/dev_tools/bin/bm install -p /sdcard/airquality.hap  

其中，airquality.hap 为应用安装包，此处替换为实际工程的应用安装

包名称。 

6. 应用安装完成后，可点击桌面应用图标启动应用。 
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7 应用调试 

7.1 调试概述 

7.1.1 调试流程 

DevEco Studio 提供了丰富的 HarmonyOS 应用调试能力，支持 Java、JS、C/C++单语

言调试和 JS+Java、Java+C/C++跨语言调试能力，同时还支持分布式应用的跨设备调

试，帮助开发者更方便、高效的调试应用。 

HarmonyOS 应用调试支持使用模拟器进行调试，也支持使用真机设备调试。 

7.1.1.1 使用真机调试 

使用真机设备进行调试前，需要在 AppGallery Connect 中申请调试证书和 Profile 文

件，并对 HAP 进行签名后进行调试。详细的调试流程如下图所示。 
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7.1.1.2 使用模拟器调试 

使用模拟器调试，可以同时支持签名和不签名两种类型的 HAP，如果应用需要签名，则流

程与使用真机调试的流程完全一样。如果不签名，调试流程如下图所示。 

 

7.1.2 准备签名文件 

使用真机设备进行调试前，需要通过 AppGallery Connect 申请调试证书和 Profile 文件

对应用进行签名，关于申请调试证书的详细操作请参考下表。 

步骤 操作步骤 操作说明 操作指导 

1 生成密钥和证书请求文件 

使用 DevEco Studio 来生

成私钥（存放在.p12 文件

中）和证书请求文件（.csr

文件） 

生成密钥和证书请求文

件 

2 创建 AGC 项目 

申请调试证书前，需要登

录 AppGallery Connect

后创建项目。 

创建您的 AGC 项目 

3 创建 HarmonyOS 应用 

在 AppGallery Connect

项目中，创建一个

HarmonyOS 应用，用于

调试证书和 Profile 文件申

请。 

创建 HarmonyOS 应用 

4 
申请调试证书和 Profile 文

件 

在 AppGallery Connect

中申请、下载调试证书和

Profile 文件。 

申请调试证书和 Profile

文件 
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7.1.3 调试设置 

7.1.3.1 配置签名信息 

在真机设备上调试前，需要使用到制作的私钥（.p12）文件、在 AppGalllery Connect 中

申请的证书（.cer）文件和 Profile（.p7b）文件对调试的模块进行签名。 

打开 File > Project Structure，在 Modules>entry（模块名称）>Signing Configs > debug

窗口中，配置指定模块的调试签名信息。 

• Store File：选择密钥库文件，文件后缀为.p12。 

• Store Password：输入密钥库密码。 

• Key Alias：输入密钥的别名信息。 

• Key Password：输入密钥的密码。 

• SignAlg：签名算法，固定为 SHA256withECDSA。 

• Profile File：选择申请的调试 Profile 文件，文件后缀为.p7b。 

• Certpath File：选择申请的调试数字证书文件，文件后缀为.cer。 
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设置完签名信息后，点击 OK 进行保存。 

7.1.3.2 设置调试代码类型 

调试类型默认情况下为 Detect Automatically，支持 Java、JS、C/C++、JS+Java、

Java+C/C++工程的调试。只有在 JS+Java 混合工程中，如果需要单独调试 Java 代码，

这种情况下需要手动修改 Debug Type 为“Java”。 

关于各调试类型的说明如下表所示。 
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调试类型 调试代码 

Java 仅调试 Java 代码 

Js 仅调试 JavaScript 代码 

Native 仅调试 C/C++代码 

Dual(Js + Java) 调试 JS FA 调用 Java PA 场景的 JS 和 Java 代码 

Dual(Java + Native) 调试 C/C++工程的 Java 和 C/C++代码 

Detect Automatically 

新建工程默认调试器选项，根据调试的工程类型，自动启动

对应的调试器。 

说明 

JS+Java 混合工程中，如果需要单独调试 Java 代码，这种情

况下需要手动修改 Debug Type 为“Java”。 

表 1 调试类型配置项 

修改调试类型的方法如下。 

点击 Run > Edit Configurations > Debugger，在 HarmonyOS App 中，选择相应

模块， 可以进行 Java/JS/C++调试配置。 
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7.1.3.3 检查 config.json 文件属性 

在启动 Feature 模块的调试前，请检查 Feature 模块下的 config.json 文件的 abilities 数

组是否存在“visible”属性，如果不存在，请手动添加，否则 Feature 模块的调试无法进

入断点。Entry 模块的调试不需要做该检查。 

1. 在工程目录中，点击 Feature 模块下的 src > main > config.json 文件，检查

abilities 数组是否存在“visible”属性。 
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• 存在 visible 属性，且取值为 true：可以正常启动调试。 

• 不存在，或者取值为 false，请根据 2 进行设置。 

2. 在 abilities 数组中手动添加“visible”属性，取值为 true。 

说明 

如果 Feature 模块手动添加了“visible”属性为 true，表示该模块可以被其它的

应用所调用。如果您不允许该模块被其它应用调用，请在调试完成后手动删除

visible 属性。 

7.1.4 启动调试 

1. 在工具栏中，点击 Debug 。 

2. 在弹出的界面，选择需要调试的设备。 

• 真实设备：一般为可以用 USB 或 IP 方式连接的实体设备。 

• 远程模拟器 ：支持 Phone、Tablet、Car、TV、Wearable 等设备，请参

考使用模拟器运行应用启动连接设备后，方可选择进行调试。 

3. 如果需要设置断点调试，则需要选定要设置断点的有效代码行，在行号（比如：

24 行）的区域后，单击鼠标左键设置断点（如图示的红点）。 
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设置断点后，调试能够在正确的断点处中断，并高亮显示该行。 

4. 启动调试后，开发者可以通过调试器进行代码调试。调试器的功能说明如下表所

示。 

按钮 名称 快捷键 功能 

 Resume 

Program 

F9（Mac 为

Option+Command+R） 

当程序执行到断点时停止执行，点击此按

钮程序继续执行。 

 Step 

Over 
F8（Mac 为 F8） 

在单步调试时，直接前进到下一行（如果

在函数中存在子函数时，不会进入子函数

内单步执行，而是将整个子函数当作一步

执行）。 

 Step 

Into 
F7（Mac 为 F7） 

在单步调试时，遇到子函数后，进入子函

数并继续单步执行。 

 

Force 

Step 

Into 

Alt+Shift+F7（Mac 为

Option+Shift+F7） 
在单步调试时，强制下一步。 
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按钮 名称 快捷键 功能 

 Step 

Out 

Shift+F8（Mac 为

Shift+F8） 

在单步调试执行到子函数内时，点击

Step Out 会执行完子函数剩余部分，并

跳出返回到上一层函数。 

 
Stop 

Ctrl+F2（Mac 为

Command+F2） 
停止调试任务。 

 Run To 

Cursor 

Alt+F9（Mac 为

Option+F9） 
断点执行到鼠标停留处。 

表 2 调试器按钮 

7.1.5 断点管理 

在设置的程序断点红点处，点击鼠标右键，然后点击 More 或按快捷键 Ctrl+Shift+F8

（Mac 为 Shift+Command+F8），可以管理断点。 
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代码类型 断点管理 

JS（JavaScript） 普通行断点 

Java 

• 普通行断点 

• Exception（异常）断点 

C/C++ 

• 普通行断点 

• Exception（异常）断点 

• Symbolic（符号）断点 

• 设置 Watchpoint（仅支持 x86、x86_64 架构） 

表 3 不同代码类型的断点管理功能 

 

 

7.2 各语言调试功能 

7.2.1 JS/JAVA 跨语言调试 

在 HarmonyOS 应用开发中，通常会涉及到使用 JS 和 Java 语言同时开发的场景，一般使

用 JS 来开发应用的 UI，使用 Java 开发应用的逻辑，JS FA 调用 Java PA。针对这种场

景，DevEco Studio 提供了 JS/Java 跨语言的调试功能，包括 JS 和 Java 断点的管理、调

试信息的展示、单步调试等能力，方便开发者快速发现并解决 JS FA 调用 Java PA 相关代

码的问题。 

在使用 JS/Java 跨语言调试设置断点时需注意，JS FA 是调用者，Java PA 是被调用者，

需要在 JS FA 调用 Java PA 的代码行或者在 Java PA 相关代码处（如 onRemoteRequest

函数）设置断点，才能正常进入 Java 断点。 
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说明 

暂不支持 JS FA 异步调用 Java PA 场景的跨语言调试。 

JS/Java 跨语言调试的操作方法如下： 

1. 在菜单栏点击 Run > Edit Configurations，选择 HarmonyOS APP 下的模块名

（如 entry），然后在右侧窗口中选择“Debugger”。 

 

2. 检查和设置“Debug type”，请选择 Dual（Js+Java）或者 Detect 

Automatically 选项。 

3. 在 JS FA 调用 Java PA 处或者在 Java PA 的相关代码处设置断点。 

4. 点击按钮或者快捷键 Shift+F9，启动调试。 
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• 如果在 JS FA 调用 Java PA 代码行处设置断点：进入断点后，点击 Step 

Into，快捷键为 F7（Mac 为 F7），进入 Java PA 函数体，然后进行 Java 

PA 的调试。 

 

• 如果在 Java PA 相关代码行处设置断点：进入断点后，点击 Resume 

Program，快捷键为 F9（Mac 为 Option+Command+R），开始 Java 

PA 的调试。 

 

 

7.2.2 Java 语言调试 

变量可视化 

在 HarmonyOS 应用调试过程中，查看变量的变化过程是否符合预期结果是一项常用的调

试方法。为此 DevEco Studio 提供了变化的可视化功能，不仅可以查看变量的当前值，还
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可以显示变量的变化过程，简单直观、迅速有效的帮助开发者定位问题。变量可视化支持

当前值可视化和连续变化值可视化两种方式。 

当前值可视化 

当前值可视化：通过解析 Debugger 当前帧的信息，获取指定变量当前栈帧中的值，以

Plain（字符）、Line（折线图）、Bar（柱状图）和 Table（表格）方式进行可视化展

示。当前值可视化每次只能观察一个变量，开发者可以根据需要切换变量进行观察。 

支持的数据类型包括基本类型（包括基本数据类型和基本数据类型的包装类）、基本类型

的集合和表达式（结果为基本数据类型和基本数据类型的包装类），支持的呈现形式如下

表所示： 

数据类型 支持的展示类型 

数值类型：byte、short、int、

long、float、double 

Plain（字符）、Line（折线图）、Bar（柱状图）和 Table

（表格） 

字符类型：char、string Plain（字符）和 Table（表格） 

布尔类型：boolean Plain（字符）和 Table（表格） 

包含数值类型的有序结构：List、

vector 

Plain（字符）、Line（折线图）、Bar（柱状图）和 Table

（表格） 

包含数值类型的无序结构：set Plain（字符）和 Table（表格） 

包含字符类型和布尔类型的结构 Plain（字符）和 Table（表格） 

Plain（字符）显示结果示意图 
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Line（折线图）显示结果示意图 

 

Bar（柱状图）显示结果示意图 
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Table（表格）显示结果示意图 

 

连续变化值可视化 
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连续变化值可视化：通过坐标图的方式，可以同时显示多个变量的连续变化过程，以及变

量之间的关系。连续变化值可视化，只支持基本数值类型的数据可视化。 

 

在连续变化值可视化中，会呈现所有变量的连续变化结果，其中横坐标为断点命中

clock，纵坐标为变量值，从添加观察变量的 clock 开始记录变量值的连续变化。在图中，

圆圈符号表示支持（只有数值类型支持）连续变化值可视化，三角符号表示不支持。在图

中如果有多个变量的连续变化图，为方便查看其中指定的变量的变化趋势，避免非观察变

量带来的影响，开发者可以点击图形上方的变量名，将其设置为灰色，这样就可以在坐标

图中隐藏该变量，再次点击灰色的变量名，则在坐标图中呈现出该变量的连续变化值。 

说明 

横坐标记录范围最大为 100，超过 100 后，则从 1 开始清除前面的数据。 
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另外，在连续变化值可视化中，可以点击 clock 节点，会自动跳转到对应值的代码行（断

点位置），并且会高亮显示代码行和 clock 时钟，如下图所示。 
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变量可视化操作指导 

Java 变量可视化使用方法： 

1. 在 Java 源码中打上断点，并启动调试功能。 

2. 打开 Java 变量可视化调试窗口，包括如下两种方式。请注意，变量可视化功能最多同时支持 10

个变量，如果超过 10 个变量，请在“Observed Variable”下拉列表中，删除正在显示的变量

后添加。 

• 方式一：在菜单栏中点击 Tools > X-Ray Debugger，然后在可视化窗口中，添加变

量。 

• 方式二：在编辑器或者调试变量栏窗口中，选中变量，点击鼠标右键，选中“Add to 

Visual Watches”，自动将该变量添加到可视化窗口中。 

3. 查看变量的当前值和连续变化值。 
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7.3 跨设备分布式应用调试 

开发者可以通过 HarmonyOS Interface Definition Language（简称 HarmonyOS IDL）

实现不同设备之间的跨进程通信（IPC，Inter-Process Communication），即开发者可

以在一个设备上访问另一个设备的进程或者调用另一个设备的方法，实现多设备的协同能

力。关于 HarmonyOS IDL 的实现请参考定义 HarmonyOS IDL 接口。 

因此，DevEco Studio 基于 HarmonyOS IDL 实现的跨设备的分布式场景，提供了跨设备

的 HarmonyOS 分布式应用的调试功能，方便开发者调测分布式应用。 

前提条件 

• 工程中至少包含 2 个及以上的模块，且模块代码是基于 HarmonyOS IDL 的 Java 语言实现。 

• 调测的多个设备成功组网，包括连接到同一个 Wi-Fi 网络、登录同一个华为帐号和同时打开蓝牙

开关。 

• 需选择真机设备，并且已与 PC 正常连接。 

操作步骤 

1. 添加跨设备调试配置。如果工程已自动生成跨设备调试配置项，可跳过该步骤。 

a. 在菜单栏选择 Run > Edit Configurations，进入“Run/Debug Configurations”

界面。 

b. 点击按钮，选择“HarmonyOS CrossDevice”配置项。 
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c. 添加完成后，点击 OK 按钮，关闭调试配置窗口。 

2. 在涉及跨设备调用的代码行设置断点。 

3. 选择已创建的跨设备调试配置（Cross-device）选项，单击按钮启动调试。 

 

4. 在弹出的设备选择窗口，指定调试设备对应的模块名称。 
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5. 启动调试后，DevEco Studio 将按照勾选的多个设备，分别启动多个调试会话窗口，命名为：

“调试配置名-模块名”，如 Cross-device-watch。 

 

6. 在代码执行到断点处（跨设备调用的代码处），点击 Step Into，快捷键为 F7（Mac 为 F7），则

会自动跳转到被调用代码接口方法处。 

例如，在上图中的调试界面为例，在 Phone 中调用 TV 的音乐播放能力，单击 Step Into，调试

窗口将从“Cross-device-watch”跳转到“Cross-device-tv”窗口，同时，代码也会跳转到对

应的接口方法处，无需开发者手动设置断点。 
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7.4 HiTrace 日志跟踪定位分析 

在 HarmonyOS 跨设备分布式应用的问题定位过程中，由于跨设备之间的调用关系复杂，

导致问题定位困难。DevEco Studio 提供了 HiTrace 日志跟踪的能力，可以分析和梳理跨

设备分布式应用之间的调用关系，通过分析调用链，方便开发者定位调用异常、性能瓶颈

等问题。 

前提条件 

• 工程中至少包含 2 个及以上的模块，且模块代码是基于 HarmonyOS IDL 的 Java 语言实现。 

• 调测的多个设备成功组网，包括连接到同一个 Wi-Fi 网络、登录同一个华为帐号和同时打开蓝牙

开关。 

• 需选择真机设备，并且已与 PC 正常连接。 

操作步骤 

1. 在设备上运行应用，跨设备运行分布式应用的方法请参考运行/调试分布式应用。 

2. 在需要跟踪调用链的 RPC 调用处，前后分别添加 Hitrace 类接口，用于采集 Hitrace 日志。对

应的示例代码如下所示： 

1.     HiTraceId traceId = HiTrace.begin("MyServiceName", 

HiTrace.HITRACE_FLAG_DEFAULT); 

2.     ...... 

3.     HiTrace.end(traceId); 

3. 在菜单栏选择 Tools > Enable Hitrace，然后点击底部工具栏中的“HiTrace”打开 HiTrace 窗

口。 
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4. 在 Hitrace 窗口，点击（Start Record）按钮，开始收集 Hitrace 日志信息，然后在设备上操作

分布式应用。 

5. 点击（Stop Record）按钮，停止收集 Hitrace 日志信息。 

6. 在收集的调用链信息中，可以呈现出设备与进程之间的调用关系，开发者通过分析调用链信息分

析问题。 

在调用链信息中，可以查看调用的设备之间、进程之间、同一个进程内的调用关系和调用时长，

结果。 
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o  

8 应用发布 
 

发布流程 

开发者完成 HarmonyOS 应用开发后，需要将应用打包成 APP，用于发布到华为应用市

场。发布应用的流程如下图所示。 

 

关于以上流程的详细介绍，请继续查阅本章节内容。 

 

准备签名文件 

发布到华为应用市场的 HarmonyOS 应用，需要在 AppGallery Connect 中申请发布证书

和 Profile 文件，并对应用进行签名。关于申请发布证书的详细操作请参考下表。 

步骤 操作步骤 操作说明 操作指导 

1 生成密钥和证书请求文件 
使用 DevEco Studio 来

生成私钥（存放在.p12 文

生成密钥和证书请求文

件 
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步骤 操作步骤 操作说明 操作指导 

件中）和证书请求文件

（.csr 文件） 

2 创建 AGC 项目 

申请发布证书前，需要登

录 AppGallery Connect

后创建一个项目。 

说明 

如果在申请调试证书时已

经创建了项目和应用，则

可以跳过“创建 AGC 项

目”和“创建

HarmonyOS 应用”步

骤。 

创建您的 AGC 项目 

3 创建 HarmonyOS 应用 

在 AppGallery Connect

项目中，创建一个

HarmonyOS 应用，用于

发布证书和 Profile 文件

申请。 

创建 HarmonyOS 应用 

4 
申请发布证书和 Profile 文

件 

在 AppGallery Connect

中申请、下载发布证书和

Profile 文件。 

申请发布证书和 Profile

文件 

用于发布的证书和 Profile 文件后，请在 DevEco Studio 中进行签名，请参考配置签名信

息。 

 

配置签名信息 

编译构建 APP 需要使用到制作的私钥（.p12）文件、在 AppGalllery Connect 中申请的

证书（.cer）文件和 Profile（.p7b）文件。然后在 DevEco Studio 中对工程进行配置。 
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在 File > Project Structure > Project > Signing Configs 窗口中，配置工程的签名信

息。 

• Store File：选择密钥库文件，文件后缀为.p12。 

• Store Password：输入密钥库密码。 

• Key Alias：输入密钥的别名信息。 

• Key Password：输入密钥的密码。 

• SignAlg：签名算法，固定为 SHA256withECDSA。 

• Profile File：选择申请的发布 Profile 文件，文件后缀为.p7b。 

• Certpath File：选择申请的发布数字证书文件，文件后缀为.cer。 

 

设置完签名信息后，点击 OK进行保存，然后使用 DevEco Studio 生成 APP，请参考编译

构建 APP。 

 

编译构建 APP 
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打包 APP 时，DevEco Studio 会将工程目录下的所有 HAP 模块打包到 APP 中，因此，

如果工程目录中存在不需要打包到 APP 的 HAP 模块，请手动删除后再进行编译构建生成

APP。 

1. 点击 Build > Build APP(s)/Hap(s) > Build APP(s)，等待编译构建完成已签名

的 APP。 

2. 编译构建完成后，可以在 build > outputs > app > release 目录下，获取带签

名的 APP。 

 

 

发布 APP 到华为应用市场 

将 HarmonyOS 应用打包成 APP 后，通过 AppGallery Connect 将 HarmonyOS 应用分

发到不同的设备上。您可以根据发布 HarmonyOS 应用指导将 APP 上架到华为应用市

场。 


